Tranmission - Port Forwarding

Discussion in 'OS X and OS X Apps' started by blackiridium, May 10, 2007.

  1. blackiridium

    blackiridium Member

    Joined:
    Dec 21, 2006
    Messages:
    338
    Likes Received:
    0
    Location:
    Sydney, Australia
    Just a (stupid) question for the experts here:

    I checked my settings last night and noticed that my Transmission settings weren't allowing port forwarding. Is it possible that my Mac's stealth settings are affecting the process of port forwarding on Transmission or is it a different matter altogether (and have I managed to muck it all up)?

    I'm getting pretty decent download rates and all that but I just feel it might be better with the port forwarding up and running the way it should.

    I tried to follow the instructions on the help feature but for some reason, it still refused to do so.

    Any thoughts or pointers would be much appreciated.

    Thanks!
    Third
     
  2. dinxcarin

    dinxcarin Active Member

    Joined:
    Apr 7, 2006
    Messages:
    1,034
    Likes Received:
    1
    Location:
    Singapore
    This happened to me too. . A torrent website has detected that I am not fully connected to the server that's why my files are taking ages to download. Need to open a port to speed up the ins/outs of datas. just hope some torrent experts would be willing to SOS. :cool:
     
    #2 dinxcarin, May 10, 2007
    Last edited: May 10, 2007
  3. marvinp

    marvinp Active Member

    Joined:
    Apr 8, 2004
    Messages:
    906
    Likes Received:
    64
  4. blackiridium

    blackiridium Member

    Joined:
    Dec 21, 2006
    Messages:
    338
    Likes Received:
    0
    Location:
    Sydney, Australia
    Thanks but I tried this out as well, for some reason, didn't work. :slanted:

    EDIT:
    I think I've got it now, but I won't know for sure til I actually try it. I'll run home for lunch later and see if it works. :)
     
    #4 blackiridium, May 10, 2007
    Last edited: May 10, 2007
  5. jopoy

    jopoy Member

    Joined:
    Sep 20, 2006
    Messages:
    54
    Likes Received:
    0
    Hi blackiridium.

    marvinp's suggestion is not working probably because random ports are being used.

    Try this instead...

    Assign/reserve a static ip for your mac and on your router configure DMZ and point it to the ip your mac. The point of DMZ is to expose your mac to the public internet.

    hth.

    'jopoy
     
  6. kaloyster

    kaloyster Member

    Joined:
    Sep 23, 2006
    Messages:
    634
    Likes Received:
    0
    Location:
    Earth
    Yeah, I also cannot port forward using 9090. And I already sought help throught portforward.com but to no avail. Any help?

    I'm using a Linksys WRT54GC:

    [​IMG]
     
  7. blackiridium

    blackiridium Member

    Joined:
    Dec 21, 2006
    Messages:
    338
    Likes Received:
    0
    Location:
    Sydney, Australia
    Thanks for this. Yep, I'll try this one later. I guess I'll have to disable 'stealth' on my Mac right? (or will I?)

    In any case, I hope it works. I'll update this thread either way.

    Cheers,
    Third
     
  8. lamski

    lamski PhilMUG Addict Member

    Joined:
    May 8, 2005
    Messages:
    2,822
    Likes Received:
    423
    Location:
    Makati, Philippines
    It's not a good idea to access the internet without a firewall so don't turn your mac's firewall off. What you need to do is to configure your router's port forwarding. To do this, you need to assign a static IP for your mac in your router. Then you need to assign the port/s that will be forwarded to the static IP you assigned to your mac. In your torrent client, you need to tell it what port you used in the router. See your router's user manual for instructions on how to do this.

    You will then need to configure your mac's network settings so that it uses the static IP you configured in the router.

    For transmission, you need to pick either NAT (Incoming TCP Port) or the automatic port mapping checkbox. Not both. So if you want to use port forwarding, you need to unselect the automap checkbox. If you did your router configuration correctly, you'll see transmission confirm that the port is indeed open.
     
  9. kaloyster

    kaloyster Member

    Joined:
    Sep 23, 2006
    Messages:
    634
    Likes Received:
    0
    Location:
    Earth
    @lamski: my router's user manual doesn't tackle this.
     
  10. lamski

    lamski PhilMUG Addict Member

    Joined:
    May 8, 2005
    Messages:
    2,822
    Likes Received:
    423
    Location:
    Makati, Philippines
  11. kaloyster

    kaloyster Member

    Joined:
    Sep 23, 2006
    Messages:
    634
    Likes Received:
    0
    Location:
    Earth
    Hope you can help me, lamski.

    Here is my router setup:

    - PC has the router
    - iMac connects to router thru Airport
    - I can configure my router thru the PC only
     
  12. lamski

    lamski PhilMUG Addict Member

    Joined:
    May 8, 2005
    Messages:
    2,822
    Likes Received:
    423
    Location:
    Makati, Philippines
    Have you tried configuring your router as outlined in portforward.com?

    Are you able to access your router's administration page? On any machine connected to your router, open any browser (IE, Firefox, Safari, Opera, Camino, etc) and type http://192.168.1.1 in the address bar and press enter. You should be prompted for the admin user and password. From there, read the middle part of the link I put above from portforward.com.
     
  13. kaloyster

    kaloyster Member

    Joined:
    Sep 23, 2006
    Messages:
    634
    Likes Received:
    0
    Location:
    Earth
    The thing is, I'm not using BitTorrent. I'm using Transmission. Your link redirects me into configuring a BitTorrent client.
     
  14. anchorite

    anchorite Member

    Joined:
    Jun 21, 2006
    Messages:
    602
    Likes Received:
    12
    Hi Kaloyster.

    Transmission is a BitTorrent client. :)
     
  15. anchorite

    anchorite Member

    Joined:
    Jun 21, 2006
    Messages:
    602
    Likes Received:
    12
    BTW, did you already check Transmission's help? There's a Portforwarding FAQ there with links to instructions on how or what you need to setup on your router. :) HTH
     
  16. blackiridium

    blackiridium Member

    Joined:
    Dec 21, 2006
    Messages:
    338
    Likes Received:
    0
    Location:
    Sydney, Australia
    So frustrating.... I thought I had it already....

    Can't seem to make the dang thing work :( I've followed all the suggestions but I'm still getting the 'Port is Stealth' notification :(
     
  17. lnara

    lnara Member

    Joined:
    Jul 28, 2005
    Messages:
    73
    Likes Received:
    0
    ISPs can sometimes block NAT and port forwarding. On the Azureus FAQ, PLDT is listed as a "bad ISP" because NAT is blocked by their servers. I'm still trying to figure a way around this too.
     
  18. lamski

    lamski PhilMUG Addict Member

    Joined:
    May 8, 2005
    Messages:
    2,822
    Likes Received:
    423
    Location:
    Makati, Philippines
    Use a higher but different number for the port. I use 50001-500010.
     
  19. anchorite

    anchorite Member

    Joined:
    Jun 21, 2006
    Messages:
    602
    Likes Received:
    12
    Hi.

    Here's my post for Azureus that details how to punch open ports in the OSX's firewall. Just replace the port value with what you have in your Transmission's preferences.

    HTH.
     
  20. blackiridium

    blackiridium Member

    Joined:
    Dec 21, 2006
    Messages:
    338
    Likes Received:
    0
    Location:
    Sydney, Australia
    I'll try this out later! Thanks Anchorite!

    Cheers,
    Third
     

Share This Page

  • About PhilMUG

    Since the mid-1990s, PhilMUG (formerly the Philippine Macintosh Users Group) has grown to become not just the Philippines’ but one of the world’s foremost Apple user groups. Our online community brings together thousands of members from the Philippines and around the world for the latest news and discussions covering all Apple products and related hardware and software. Anyone can join PhilMUG, from newbies to experts, subject to our membership rules and guidelines.
  • Like us on Facebook

  • Buy us a beer!

    The staff works very hard to make sure that PhilMUG is running 24/7. Care to buy us a beer or help out with our hosting fees? We'd really appreciate it!

    Donate to us!