empty font book

Discussion in 'OS X and OS X Apps' started by chinggay, May 30, 2008.

  1. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    I transferred all the fonts in my library from one computer to another. They all run fine in the old computer (which runs on Tiger). In the new computer (running on Leopard), I can see and use the fonts in all the programs (word, indesign, etc.) without a hitch.

    Despite my having transferred the fonts and my being able to use them however, my Font Book remains empty (0 Fonts!). Under the "Collection" area on the left side of Font Book, there's an untitled and empty collection, plus one collection entitled "English" that has 0 fonts as well.

    I tried dragging the fonts manually from the user library into Font Book, but nothing gets copied.

    I also opened Font Book's preferences to try and change the default install location, but it's unclickable. I know there's supposed to be a "user" collection in Font Book, but there's nothing in there!

    I've gone through Apple support site and google, and haven't found an answer. If anyone can help, it'd be greatly appreciated! Thanks. :)
     
  2. Libra

    Libra Member

    Joined:
    May 18, 2008
    Messages:
    596
    Likes Received:
    0
    Location:
    Quezon City
    Hi chinggay,

    I also did the same thing when I got my macbook. I copies the fonts that I wanted from my old computer. When I copy/paste it in the font book (not sure if there was any difference between dragging and copy/paste). Though the original fonts were there, the new ones also appeared in the font book instantaneously. But when I tried using the fonts in a word document, the new ones did not appear.

    The next day (when I powered up my mac), and had to open a word document, when I was changing the font the new ones appeared.

    Question: Did you drag or copy/paste in the "All Fonts" collection of the font book?
     
  3. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    Hi!

    The "All Fonts" collection doesn't even appear in my new Font Book. I copied the original fonts from the library of the first computer to the library of the second computer (I connected both computers via firewire) by dragging them.

    I think what happened to me is the opposite of what happened to you. My fonts can be viewed in programs like word or indesign, etc. but they can't be viewed in Font Book. It's weird because they're definitely IN the computer; but for some reason, Font Book doesn't pick them up or recognize them.

    Does your Font Book work now?
     
  4. Libra

    Libra Member

    Joined:
    May 18, 2008
    Messages:
    596
    Likes Received:
    0
    Location:
    Quezon City
    Yup. It worked when i shutdown and powered up.

    Your case seems to intrigued me. Even my partner is intrigued... :slanted:

    Question: Do you recall that when you were transferring the new fonts to the font book, were the fonts in the font book highlighted? If so, that would explain why the original fonts would be deleted. If it was highlighted, it would understand that those highlighted will be replaced by what you are transferring. Am I making sense?
     
  5. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    I'm not entirely sure I understand the question, but I don't think any fonts were highlighted...

    I found a couple more similar cases over the internet, but none of them were able to solve the problem!

    It's really frustrating!
     
  6. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    Just an update: I got it to finally work by starting up in safe mode, logging in, logging out, and then restarting normally.

    My problem is now, I can't seem to install fonts or add them to my collection!
     
  7. Libra

    Libra Member

    Joined:
    May 18, 2008
    Messages:
    596
    Likes Received:
    0
    Location:
    Quezon City
    There's got to be a reason why this is happening...

    I'm tracking my steps back when I copy/paste my font in the "all fonts" collection of the font book.

    Not sure which style of transferring you did but this is what I did way back:

    1. From the fonts that I wanted to transfer, I copied them (selecting the font and right click "Copy"
    2. I went to the Font Book and selected the "All Fonts" from Collection. The second column showed all the fonts from that collection.
    3. I right click "Add Fonts" from that column.
    4. It systematically pasted all the fonts I selected.

    When I messaged you earlier, when I tried to check the new fonts, I opened a word document. When it appeared I tried selecting from the fonts I transferred - nothing. The fonts are still from the original list. Since I thought what I did was futile, I went on my usual way and set it aside. At the end of the day, I shut down my computer. The next day when I powered up my mac, I had to edit a document from work. I decided to change the font of the document (thinking at that time that I'll just choose from the original fonts since I thought what did the day before didn't work). When I clicked the fonts and it dropped down, all the fonts I transferred were all there. No problems occurred from that moment on.

    I'm not sure if you've explored this but in the fonts, when you right click it, there is a selection that says "Disable (name of font)". Have you checked if those were disabled?
     
  8. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    Hi Libra, thanks so much for all your help!

    The default fonts now show up in Font Book, but all the fonts I transferred (I copied and pasted them, just like you) do not show up in All Fonts or in User. So, I'm not able to Disable them cause they don't appear at all in Font Book. :(

    I tried deleting all the fonts, clearing my caches, restarting and reinstalling and it still doesn't work. I wish I had another program like Extensis to help me with this, but unfortunately, I don't have it! Oh well.
     
  9. Libra

    Libra Member

    Joined:
    May 18, 2008
    Messages:
    596
    Likes Received:
    0
    Location:
    Quezon City
    My pleasure, chinggay. What are muggers for? ;)

    It might be a good to check for softwares that supports your requirements.

    My partner and I are very much intrigued by this. We will keep you in mind as we're trying to figure out what went wrong.
     
  10. chinggay

    chinggay Member

    Joined:
    Apr 8, 2004
    Messages:
    247
    Likes Received:
    0
    Location:
    Greenhills
    Will also keep you posted in case I find out where the glitch is... in the meantime, I'm gonna look for a better font manager!
     

Share This Page

  • About PhilMUG

    Since the mid-1990s, PhilMUG (formerly the Philippine Macintosh Users Group) has grown to become not just the Philippines’ but one of the world’s foremost Apple user groups. Our online community brings together thousands of members from the Philippines and around the world for the latest news and discussions covering all Apple products and related hardware and software. Anyone can join PhilMUG, from newbies to experts, subject to our membership rules and guidelines.
  • Like us on Facebook

  • Buy us a beer!

    The staff works very hard to make sure that PhilMUG is running 24/7. Care to buy us a beer or help out with our hosting fees? We'd really appreciate it!

    Donate to us!