Delay in Receiving iMessage

Discussion in 'Globe Telecom' started by jmkerr12, Feb 28, 2021.

  1. jmkerr12

    jmkerr12 Member

    Oct 25, 2007
    Likes Received:
    Taguig / Makati
    Is anyone experiencing delay in receiving imessage?

    i had been experiencing this for at least 4 months. Tried resolving with Apple support for 2 months but they are insisting there is no problem on their end and ask me to check with the network provider.

    the reasons i also suspect it’s a globe/ telco issue are:
    - the delay only happens on my main device where the sim card is installed. Secondary devices like other iphone, apple watch, mac and ipad can receive the message in real time
    - another friend has complained that she is not getting our imessages in our group chat. Also a globe user

    Just checking probably someone is also experiencing this? And/or might have found a solution for this issue.
  2. Invisigoth

    Invisigoth Member

    Nov 9, 2020
    Likes Received:
    Backup your iPhone through iTunes then restore your iPhone to factory settings. Log into your Apple ID then do a iMessage send.

    If there is no delay then it's probably an errant error.

    Do facory settings again then restore backup from iTunes to your iPhone

    But before you do that update to iOS 14.4 or later.

Share This Page

  • About PhilMUG

    Since the mid-1990s, PhilMUG (formerly the Philippine Macintosh Users Group) has grown to become not just the Philippines’ but one of the world’s foremost Apple user groups. Our online community brings together thousands of members from the Philippines and around the world for the latest news and discussions covering all Apple products and related hardware and software. Anyone can join PhilMUG, from newbies to experts, subject to our membership rules and guidelines.
  • Like us on Facebook

  • Buy us a beer!

    The staff works very hard to make sure that PhilMUG is running 24/7. Care to buy us a beer or help out with our hosting fees? We'd really appreciate it!

    Donate to us!