17" MBP monitor not working

Discussion in 'MacBook Air, MacBook & MacBook Pro' started by waikru, Jun 26, 2009.

  1. waikru

    waikru Member

    Joined:
    Dec 22, 2007
    Messages:
    52
    Likes Received:
    0
    good morning.

    last night, the monitor wouldn't display anything when i turned it on. the welcome tone played when i powered it up so i'm pretty sure it booted. there's also a steady light from the button that unfolds the mac.

    the keys work however i can only shut it down by manually disconnecting the battery.

    its a 17" mbp (tiger) which i bought from amazon last dec 2007.

    please help. thanks.
     
  2. anthonyramos84

    Joined:
    Jun 12, 2009
    Messages:
    165
    Likes Received:
    0
    Location:
    Ilocos Norte, Hong Kong
    Could be a loose or faulty connection. Bring it over to an Apple Service Center.
     
  3. waikru

    waikru Member

    Joined:
    Dec 22, 2007
    Messages:
    52
    Likes Received:
    0
    @anthonyramos84: thanks.

    yikes, mukhang ito ang dumale sa kin. may naka experience na kaya nito sa tin.
     
  4. Salaryman Ryan

    Salaryman Ryan PhilMUG Addict Member

    Joined:
    Oct 18, 2007
    Messages:
    5,893
    Likes Received:
    664
    Gender:
    Male
    Location:
    Tokyo, Manila
    If it is indeed the dreaded 8600M GT Nvida GPU failure - I think you are in luck, Apple has you covered as I recall Apple issued a statement that they will cover Macbook Pros with that GPU for three years regardless of it has Applecare or not. :)

    http://support.apple.com/kb/TS2377?viewlocale=en_US

    I suggest to print this article out and show it to the service center you plan to send it to, especially if your Macbook Pro is out of warranty.

    Good luck!!!
     
    #4 Salaryman Ryan, Jun 26, 2009
    Last edited: Jun 26, 2009
  5. waikru

    waikru Member

    Joined:
    Dec 22, 2007
    Messages:
    52
    Likes Received:
    0
    yep, saw that link earlier too. spoke with apple support and they've given me a service number. heading to powermac tomorrow so they can confirm if it really is the problem. it sure takes a load off. thanks
     
  6. rowinms

    rowinms Member

    Joined:
    Apr 4, 2009
    Messages:
    424
    Likes Received:
    0
    Location:
    Hong Kong
    yeap ... one of the best problems by these versions
     

Share This Page

  • About PhilMUG

    Since the mid-1990s, PhilMUG (formerly the Philippine Macintosh Users Group) has grown to become not just the Philippines’ but one of the world’s foremost Apple user groups. Our online community brings together thousands of members from the Philippines and around the world for the latest news and discussions covering all Apple products and related hardware and software. Anyone can join PhilMUG, from newbies to experts, subject to our membership rules and guidelines.
  • Like us on Facebook

  • Buy us a beer!

    The staff works very hard to make sure that PhilMUG is running 24/7. Care to buy us a beer or help out with our hosting fees? We'd really appreciate it!

    Donate to us!