Apple Watch Problem

Discussion in 'Sw!tch' started by julmercado, Mar 28, 2017.

  1. julmercado

    julmercado Member

    Joined:
    Jun 19, 2012
    Messages:
    319
    Likes Received:
    23
    My AW suddenly won't charge and I have no way to tell if my AW or the cable is the one deffective. So I went to Switch (Solenad) to check which one. But to my dismay, the sales attendant told me that they don't have any charger to test my AW. For real?! Are you fu#*ing kidding me?! You're an Apple Premium Reseller for god's sake! (n)

    I hope BTB opens here at Solenad.
     
  2. bacchus_3

    bacchus_3 Well-Known Member

    Joined:
    Apr 29, 2007
    Messages:
    4,402
    Likes Received:
    90
    Gender:
    Male
    They don't have AWs on display?
     
  3. BogeeZR

    BogeeZR New Member

    Joined:
    Nov 7, 2007
    Messages:
    8
    Likes Received:
    0
    This has happened to me before. I thought my Watch was charging overnight when it wasn't charging at all. I switched it off and on again, tried charging again and it still wouldn't. What fixed it for me was a force restart. If you haven't tried it yet, press the side button AND digital crown until the screen turns black and the Apple logo comes back on. It also happens when the Watch is completely drained - it takes a while for the display to come back on after charging.
     

Share This Page

  • About PhilMUG

    Since the mid-1990s, PhilMUG (formerly the Philippine Macintosh Users Group) has grown to become not just the Philippines’ but one of the world’s foremost Apple user groups. Our online community brings together thousands of members from the Philippines and around the world for the latest news and discussions covering all Apple products and related hardware and software. Anyone can join PhilMUG, from newbies to experts, subject to our membership rules and guidelines.
  • Like us on Facebook

  • Buy us a beer!

    The staff works very hard to make sure that PhilMUG is running 24/7. Care to buy us a beer or help out with our hosting fees? We'd really appreciate it!

    Donate to us!